Contar.si y Contar.si.conjunto en Excel

Las funciones contar.si y contar.si.conjunto de Excel te permiten contar las celdas que cumplen uno o varios criterios que has establecido. ¿Sabrías utilizarlas en cualquier caso? Con texto, cifras, símbolos de mayor, menor etc. Te lo explicamos paso a paso.

Contar si la celda coincide con un texto

Para el primer ejemplo de las funciones contar.si y contar.si.conjunto en Excel empezaremos por algo sencillo.

Contaremos las celdas cuyo texto coincide con el texto que aparece en la celda F6. Al ser un único criterio utilizaremos la función CONTAR.SI, pero también podrías utilizar la función CONTAR.SI.CONJUNTO y funcionaría exactamente igual.

Tenemos un ejemplo con 4 columnas donde se muestra el vendedor, importe de venta, sección y tipo de pago. Encontrarás la plantilla descargable al final del post.

La sintaxis de la función sería de la siguiente forma: CONTAR.SI(rango; criterio) donde:

  • Rango es el rango de celdas donde la función debe contar el criterio establecido.
  • Criterio es la regla que estableces para contar las celdas.

Queremos contar las ventas de la vendedora Carolina. En la celda I6 escribe =CONTAR.SI.

El rango serán todos los datos de la columna vendedor. Selecciona la primera celda y presiona CTRL+SHIFT+⬇ para seleccionar todos los datos de la columna.

El criterio será la celda F6 donde está escrito el nombre de la vendedora Carolina.

La función quedaría así: =CONTAR.SI(A2:A21;F6)

También puedes escribir directamente el texto en la función, en este caso la función quedaría así =CONTAR.SI(A2:A21; «carolina» )

RECUERDA. Cuando introduces texto en la funciones siempre debe ir entrecomillado. Excel no distingue entre mayúsculas y minúsculas, pero sí debes escribir siempre las tildes si es necesario.

Contar si valor < valor_criterio

También podemos usar la función CONTAR.SI con valores numéricos. En el segundo ejemplo contaremos las ventas cuyo importe sea inferior a 30€. En la celda F7 tienes escribo <30.

Para ello escribimos la función CONTAR.SI:

El rango serán todos los importes de venta y el criterio será la celda F7. Quedando la función así: =CONTAR.SI(B2:B21;F7)

En este caso con valores numéricos y símbolos de < o > hay más formas de introducirlo en la función.

Puedes introducir el criterio completo como texto, en este caso tendría que ir entrecomillado y la función quedaría así: =CONTAR.SI(B2:B21;»<30″)

Además, puedes introducir el símbolo < en la función y hacer referencia a la celda donde tienes escrito el valor numérico (solo el valor numérico sin el símbolo <).

En ese caso el símbolo < debe ir en la función entre comillas y tienes que utilizar el símbolo & para unirlo a la referencia de la celda, quedando la función así: =CONTAR.SI(B2:B21;»<«&F7)

Como acabas de ver en Excel suelen existir varias soluciones para un mismo problema. En este caso hemos visto 3 formas de llegar a un mismo resultado.

CONTAR SI CONJUNTO en Excel

Utiliza la función CONTAR.SI.CONJUNTO cuando necesites evaluar más de un criterio para contar las celdas. Pero también puedes usarla cuando tengas un único criterio.

En este ejemplo contaremos las ventas de la sección perfumería que han sido pagadas al contado.

Para ello usa la función CONTAR.SI.CONJUNTO donde:

  • Rango_criterio1 será el rango de las secciones de la tabla.
  • Criterio_1 será la celda F8 donde aparece el nombre de la sección perfumería.
  • Rango_criterio2 será la columna de formas de pago
  • Criterio_2 será la celda G8 donde aparece el valor.

La función quedaría así: =CONTAR.SI.CONJUNTO(C2:C21;F8;D2:D21;G8)

En este caso ambos criterios son de texto, recuerda que también puedes escribirlo directamente en la función entre comillas.

CONTAR SI CONJUNTO con criterios de texto y numéricos

En el tercer ejemplo contaremos las ventas de Carolina, pagadas al contado y de un importe inferior a 40€.

La función quedaría así =CONTAR.SI.CONJUNTO(A2:A21; « carolina»;D2:D21;G9;B2:B21;»<40″)

Recuerda que tanto para criterios de texto como numéricos puedes usar diferente variantes. Te recomendamos ir variando la forma de introducir criterios para fijar conceptos y tener más recursos en el manejo de Excel.

Plantilla del ejercicio

Puedes descargarte la plantilla del ejercicio para practicar aquí:

⚠ Esta plantilla es un recurso creado por Saber Programas y su uso está sujeto a derecho de autor y propiedad intelectual.

¿Conocías todas las formas de introducir criterios de texto o valores en la función contar.si y contar.si.conjunto?

¡Puntúa este artículo!

Haz clic en las estrellas para puntuar

Promedio 5 / 5. Recuento de votos 3

Nadie ha votado aún. ¡Se el primero en puntuar esta publicación!

Haz un comentario

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información.plugin cookies

ACEPTAR
Aviso de cookies