La nueva funci贸n BUSCARX de Excel ha venido para quedarse y, sobre todo, para facilitarnos mucho la vida. Esta funci贸n puede sustituir otras funciones de b煤squeda como buscarv, buscarh, 铆ndice y coincidir. Te ense帽amos todas las posibilidades en este tutorial.

驴En qu茅 versi贸n de Excel est谩 disponible la funci贸n BUSCARX?

La funci贸n BUSCARX est谩 disponible para Excel 365, si tienes una versi贸n antigua de Excel, como Excel 2010 o Excel 2016 no tendr谩s esta funci贸n.

Puedes comprobar si tu Excel tiene la funci贸n escribiendo en cualquier celda =buscar

En las funciones disponibles debe aparecer BUSCARX.

Tambi茅n puedes comprobar la versi贸n de tu Excel. Clica en Archivo, en el men煤 izquierdo selecciona la opci贸n Cuenta y comprueba en el apartado Acerca de Excel la versi贸n que est谩s utilizando.

La funci贸n est谩 disponible desde la versi贸n 1910 de Excel.

C贸mo usar la funci贸n BUSCARX en Excel

Para ver el uso de la funci贸n BUSCARX en Excel utilizaremos un ejemplo en el que se muestra un listado de comerciales, la zona en la que trabajan y las ventas anuales. En otra hoja llamada bonificaci贸n tenemos otra tabla con el ID de cada comercial, su nombre y el porcentaje bonificaci贸n sobre las ventas que han conseguido. Puedes descargarte la plantilla al final de este art铆culo.

Utilizando la funci贸n BUSCARX queremos calcular el importe de la bonificaci贸n sobre las ventas que han conseguido. Necesitamos buscar el porcentaje de bonificaci贸n para cada uno de los comerciales.

En la primera celda de la columna correspondiente escribe =BUSCARX donde:

  • Valor_buscado ser谩 el nombre del comercial que tambi茅n aparece en la lista de bonificaciones.
  • Matriz_buscada corresponde a toda la columna de nombres de comerciales en la tabla de la hoja bonificaci贸n (establecemos una referencia absoluta presionando F4)
  • Matriz_devuelta son todos los datos de la columna porcentajes de bonificaci贸n, tambi茅n fijaremos este valor pulsando F4.

Estos 3 son los argumentos obligatorios de la nueva funci贸n BUSCARX. Los otros 3 argumentos son opcionales, los veremos con otros ejemplos.

La funci贸n quedar铆a as铆:

=BUSCARX(A5;Bonificaciones!$B$6:$B$25;Bonificaciones!$C$6:$C$25)

Nos devuelve el valor de la bonificaci贸n, para calcular el importe solo debes multiplicar ese valor por el importe de ventas, quedando de la siguiente forma:

=BUSCARX(A5;Bonificaciones!$B$6:$B$25;Bonificaciones!$C$6:$C$25)*C5

Como evitar error #N/D

Observa que al arrastrar la funci贸n al resto de celdas de la columna, en algunos casos arroja el error #N/D.

BUSCARX en Excel

Este error suele aparecer cuando utilizamos las funciones BUSCARV, BUSCARH, BUSCAR, COINCIDIR y tambi茅n en la nueva funci贸n BUSCARX y se produce cuando en una f贸rmula no se encuentra el valor al que se hace referencia. Como en este caso, algunos de los nombres de los comerciales no existen en los datos de bonificaciones.

Este error es muy sencillo de solventar cuando usas la funci贸n BUSCARX. Solo tienes que aplicar un valor para el cuarto argumento de la funci贸n. Se trata del argumento Si_no_se_encuentra para ese valor aplicaremos el valor 0. Escribe ; tras el 煤ltimo argumento, antes del par茅ntesis de cierre y a continuaci贸n un 0.

La funci贸n ahora quedar铆a as铆:

=BUSCARX(A5;Bonificaciones!$B$6:$B$25;Bonificaciones!$C$6:$C$25;0)*C5

Buscar en horizontal con BUSCARX en Excel

Antes de la funci贸n BUSCARX, cuando necesit谩bamos realizar una b煤squeda en una tabla estructurada de forma horizontal deb铆amos utilizar la funci贸n BUSCARH. La nueva funci贸n BUSCARX tambi茅n puede realizar b煤squedas horizontales sin problema.

El proceso es exactamente igual. Para verlo calcularemos de nuevo la bonificaci贸n, pero en este caso usaremos la tabla horizontal de la hoja Bonificaciones.

La funci贸n realizando la b煤squeda horizontal quedar铆a as铆:

=BUSCARX(A5;Bonificaciones!$G$8:$Z$8;Bonificaciones!$G$9:$Z$9;0)*C5

Caracteres comod铆n en BUSCARX

En algunos casos necesitamos realizar b煤squedas con coincidencia parcial. En esos casos podemos usar tanto asteriscos como signos de interrogaci贸n y combinarlos con el valor buscado. Vamos a ver c贸mo aplicarlo en la funci贸n BUSCARX.

Supongamos que no conocemos el nombre de todos los comerciales, pero s铆 su apellido. Queremos que al introducir el apellido en una celda obtener la bonificaci贸n usando la funci贸n BUSCARX donde:

  • Valor_buscado ser谩 el apellido que se muestra en la celda G7. Para indicar que puede haber texto delante escribiremos justo delante de la referencia a la celda 鈥*鈥 y para unirlo a la referencia de la celda usa el s铆mbolo &. Quedando el primer argumento de la siguiente forma: =BUSCARX(芦*禄&G7;
  • Matriz_buscada corresponde a toda la columna de nombres de comerciales.
  • Matriz_devuelta son todos los datos de la columna bonificaci贸n que has calculado anteriormente.

Como la b煤squeda que est谩s realizando no es una b煤squeda exacta debes indicarlo en el quinto argumento de la funci贸n BUSCARX para que funcione correctamente. El cuarto argumento lo dejaremos vac铆o.

BUSCARX en Excel

En el quinto argumento modo_de_coincidencia existe la opci贸n coincidencia de caracteres comod铆n, que debes seleccionar en estos casos. Su valor es 2.

Quedando la funci贸n de la siguiente forma:

=BUSCARX(芦*禄&G7;A5:A19;D5:D19;;2)

Buscar por fila y columna con BUSCARX

Utilizando la funci贸n BUSCARX tambi茅n puedes realizar b煤squedas bidireccionales. Para buscar un valor tanto en las filas como en las columnas, us谩bamos las combinaciones de funciones BUSCARV Y COINCIDIR o bien INDICE y COINCIDIR. Con la funci贸n BUSCARX ya no necesitas utilizar dos funciones separadas. Puedes utilizar la BUSCARX anidada.

En la plantilla tenemos hemos insertado una lista desplegable en la que se elige el comercial y otra lista en la que se selecciona el campo a mostrar (Zona, ventas anual o bonificaci贸n) queremos armar una funci贸n BUSCARX que muestre el dato correspondiente al comercial y campo seleccionado.

En este caso en la funci贸n BUSCARX:

  • Valor_buscado ser谩 el la celda donde hemos insertado la lista desplegable con los nombres de comercial H15.
  • Matriz_buscada corresponde a toda la columna de nombres de comerciales A5:A19.
  • Matriz_devuelta depender谩 del campo seleccionado, por lo que escribiremos de nuevo otra funci贸n BUSCARX donde:
    • Valor_buscado de la segunda buscarx ser谩 el campo seleccionado que se muestra en la celda G16.
    • Matriz_buscada de la segunda buscarx ser谩n los encabezados donde se muestran los tres campos B4:D4.
    • Matriz_devuelta de la segunda buscarx ser谩n todos los datos B5:B19.

Quedando la funci贸n de la siguiente forma:

=BUSCARX(H15;A5:A19;BUSCARX(G16;B4:D4;B5:D19))

BUSCARX en Excel

Buscar valores aproximados con BUSCARX

Cuando necesitas buscar dentro de una tabla de datos el valor m谩s aproximado, tambi茅n puedes hacerlo con la funci贸n BUSCARX. Lo puedes usar para calcular descuentos, bonificaciones etc. En este caso usaremos el argumento opcional modo de coincidencia.

Lo veremos con el siguiente ejemplo, a帽adimos una columna m谩s a los datos en la que queremos mostrar el porcentaje de bonificaci贸n que corresponde seg煤n la siguiente tabla.

Para poder calcular el porcentaje se debe buscar el valor aproximado seg煤n la tabla. Usaremos la funci贸n BUSCARX donde:

  • Valor_buscado ser谩 el importe de ventas anual.
  • Matriz_buscada corresponde a todos los importes de ventas de la tabla en la que muestra el porcentaje de bonificaci贸n por rangos.
  • Matriz_devuelta ser谩n los porcentajes de bonificaci贸n seg煤n el rango.

En este caso tampoco necesitas realizar una b煤squeda exacta, por lo que de nuevo debes usar el 5潞 argumento modo_de_coincidencia.

  • Modo_de_coincidencia debes seleccionar la opci贸n coincidencia exacta o el siguiente elemento menor, al que corresponde el valor -1.

La funci贸n quedar铆a de la siguiente forma:

=BUSCARX(C5;Bonificaciones!$F$16:$F$21;Bonificaciones!$G$16:$G$21;;-1)

Plantilla de los ejercicios

Puedes descargar la plantilla para practicar aqu铆:

Esta plantilla es un recurso creado por Saber Programas y su uso est谩 sujeto a derechos de autor y propiedad intelectual.

Resumen de la funci贸n BUSCARX

Si has seguido el tutorial completo habr谩s comprobado que la nueva funci贸n BUSCARX es muy potente y puede sustituir varias funciones. Esto hace que el manejo de Excel sea m谩s sencillo, ya que solo tendr谩s que aprender bien el uso de esta funci贸n para sustituir otras funciones.

驴Hab铆as utilizado antes esta funci贸n? Danos tu opini贸n sobre ella.

隆Punt煤a este art铆culo!

Haz clic en las estrellas para puntuar

Promedio 5 / 5. Recuento de votos 2

Nadie ha votado a煤n. 隆Se el primero en puntuar esta publicaci贸n!